Re: VXlan Tunnel Issues - Question

Marek Gradzki -X (mgradzki - PANTHEON TECHNOLOGIES@Cisco) <mgradzki@...>

Hi Patricio,

I haven't experienced anything similar.
Have you tried asking GBP/VBD developers?
Another option might be

Have you checked what messages are actually sent from ODL
log:set TRACE org.opendaylight.netconf.sal.connect.netconf.listener ?

To see what was received by HC, use:
<logger name="org.opendaylight.netconf.nettyutil.handler.ssh.client.AsyncSshHandlerReader" level="TRACE"/>
<logger name="org.opendaylight.netconf.impl.NetconfServerSessionListener" level="DEBUG"/>

Also increasing log level for v3po component (interface management, bridge domains...) might help:
<logger name="io.fd.hc2vpp.v3po" level="TRACE"/>


-----Original Message-----
From: hc2vpp@... [mailto:hc2vpp@...] On Behalf Of Patricio Latini
Sent: 3 maja 2018 16:14
To: hc2vpp@...
Subject: [hc2vpp] VXlan Tunnel Issues - Question

I am having the following problem in my openstack lab with Opendaylight nitrogen and oxygen. Tried with honeycomb 18.01 and 18.04 and same problem

When I first Create a network, subnetwork and deploy a server everything works fine and the VXLAN tunnel is created fine between the compute host and network host.

Now if I destroy the server (VxLan tunnel removed as it is nor required anymore) and deploy a new one in the same network there is an error in the creation of the VXLAN tunnel (everything else works fine). The only way to resolve is completely delete the network and recreate.

Checking in the ODL logs there is a message referring that the Bridge Domain Could not be removed due to BridgeDomainManager not responding for 60 seconds. However I verified several times and connection between ODL and HC is not lost.

Has anybody experienced something similar?

Thanks, attaching full log


Join { to automatically receive all group messages.