[vpp-dev] Can't install honeycomb master package from nexus on xenial


Marek Gradzki -X (mgradzki - PANTHEON TECHNOLOGIES@Cisco) <mgradzki@...>
 

+ hc2vpp and honeycomb-dev

 

From: vpp-dev-bounces@... [mailto:vpp-dev-bounces@...] On Behalf Of Marek Gradzki -X (mgradzki - PANTHEON TECHNOLOGIES at Cisco)
Sent: 1 sierpnia 2017 17:17
To: Ed Warnicke <hagbard@...>; Lori Jakab <lorand.jakab+fdio@...>
Cc: Florin Coras (fcoras) <fcoras@...>; hc2vpp-dev@...; vpp-dev@...
Subject: Re: [vpp-dev] Can't install honeycomb master package from nexus on xenial

 

Hi,

 

here is example for most recent honeycomb package from master repo:

 

https://nexus.fd.io/content/repositories/fd.io.master.ubuntu.xenial.main/io/fd/hc2vpp/honeycomb/1.17.10-3130_all/honeycomb-1.17.10-3130_all-deb.deb

 

dpkg -I honeycomb-1.17.10-3130_all-deb.deb

 new debian package, version 2.0.

size 39862426 bytes: control archive=17905 bytes.

     377 bytes,    11 lines      control             

   68199 bytes,   556 lines      md5sums             

     959 bytes,    23 lines   *  postinst             #!/bin/sh

     596 bytes,    21 lines   *  postrm               #!/bin/sh

     186 bytes,     7 lines   *  prerm                #!/bin/sh

Package: honeycomb

Version: 1.17.10-3130

Architecture: all

Maintainer: fd.io/hc2vpp <hc2vpp@...>

Installed-Size: 49791

Depends: vpp (= 17.10-rc0~95-g6881062~b2627), vpp-plugins (= 17.10-rc0~95-g6881062~b2627), openjdk-8-jre-headless

Suggests: vpp-nsh-plugin

Section: misc

Priority: optional

Homepage: https://wiki.fd.io/view/Hc2vpp

Description: Honeycomb agent for VPP

 

Regards,

Marek

 

 

From: vpp-dev-bounces@... [mailto:vpp-dev-bounces@...] On Behalf Of Ed Warnicke
Sent: 1 sierpnia 2017 16:47
To: Lori Jakab <lorand.jakab+fdio@...>
Cc: Florin Coras (fcoras) <fcoras@...>; vpp-dev@...; hc2vpp-dev@...
Subject: Re: [vpp-dev] Can't install honeycomb master package from nexus on xenial

 

Do the honeycomb 17.10 packages depend on the release vpp 17.10 packages?

 

Ed

 

On Tue, Aug 1, 2017 at 5:20 AM, Lori Jakab <lorand.jakab+fdio@...> wrote:

On Tue, Aug 1, 2017 at 1:46 PM, Jan Srnicek -X (jsrnicek - PANTHEON TECHNOLOGIES at Cisco) <jsrnicek@...> wrote:

Hi lori

 

This is known issue with apt-get , as honeycomb packages have compatible vpp version defined ,but apt-get attempts to download the newest one.

 

To solve this , you need to first install vpp like so:

 

sudo apt-get install vpp=VERSION vpp-lib= VERSION vpp-plugins= VERSION

 

and then install honeycomb

 

I have the installation as part of a script of a Vagrantfile, so I prefer not to hardcode version numbers, but having seen the "Merge job failing" thread you started confirms that this is an anomaly, and it will get fixed eventually.

 

Thanks!

 

-Lori

 

 

banner11

 

Jan Srnicek

Engineer - Software

jsrnicek@...

Tel:

Cisco Systems, Inc.




Slovakia
cisco.com

 

Think before you print.

This email may contain confidential and privileged material for the sole use of the intended recipient. Any review, use, distribution or disclosure by others is strictly prohibited. If you are not the intended recipient (or authorized to receive for the recipient), please contact the sender by reply email and delete all copies of this message.

Please click here for Company Registration Information.

 

From: vpp-dev-bounces@... [mailto:vpp-dev-bounces@...] On Behalf Of Lori Jakab
Sent: Tuesday, August 1, 2017 10:08 AM
To: vpp-dev@...; hc2vpp-dev@...
Cc: Florin Coras (fcoras) <fcoras@...>
Subject: [vpp-dev] Can't install honeycomb master package from nexus on xenial

 

Hi,

 

I'm trying to install honeycomb on Ubuntu Xenial, after having added 'https://nexus.fd.io/content/repositories/fd.io.master.ubuntu.xenial.main' to the repository list. When installing honeycomb, I get the following error:

 

The following packages have unmet dependencies:

 honeycomb : Depends: vpp (= 17.10-rc0~95-g6881062~b2627) but 17.10-rc0~101-g5b31120~b2635 is to be installed

             Depends: vpp-plugins (= 17.10-rc0~95-g6881062~b2627) but 17.10-rc0~101-g5b31120~b2635 is to be installed

 

Is there an easy way to solve this? Maybe a honeycomb artifact publication job is failing?

 

Thanks,

-Lori

 


_______________________________________________
vpp-dev mailing list
vpp-dev@...
https://lists.fd.io/mailman/listinfo/vpp-dev