Re: apache maven wagon

Vanessa Valderrama
 

I've complied the list of jobs and pom files that are pinning version wagon 2.9. Please upgrade or unpin the version of wagon.

Here's the search used to compile the list
https://github.com/search?p=1&q=org%3AFDio+wagon-webdav-jackrabbit&type=Code

CSIT

Job configuration
 - https://git.fd.io/ci-management/tree/jjb/csit/csit.yaml
   - jobs calling the script
     csit-docs-merge-{stream_timed}

Script
 - https://github.com/FDio/ci-management/blob/8acba0b988a3a6220340df3b0d79451fb52e93e9/jjb/csit/include-raw-csit-docs.sh

Job configuration
 - https://git.fd.io/ci-management/tree/jjb/csit/csit.yaml
   - jobs calling the script
     csit-report-merge-{stream}

Script
 - https://github.com/FDio/ci-management/blob/8acba0b988a3a6220340df3b0d79451fb52e93e9/jjb/csit/include-raw-csit-report.sh

Job configuration
 - https://git.fd.io/ci-management/tree/jjb/csit/csit.yaml
   - jobs calling scripts
     csit-trending-daily-master

Script
 - https://github.com/FDio/ci-management/blob/77a5851cb279501c101e42df35d501f8afc14135/jjb/csit/include-raw-csit-cpta.sh

NSH_SFC

Job configuration
 - https://git.fd.io/ci-management/tree/jjb/nsh_sfc/nsh_sfc.yaml
   - jobs calling the script
     nsh_sfc-merge-docs-{stream}
     nsh_sfc-verify-docs-{stream}

Script
 - https://github.com/FDio/ci-management/blob/8acba0b988a3a6220340df3b0d79451fb52e93e9/jjb/nsh_sfc/include-raw-nsh_sfc-docs.sh

VPP

Job configuration
 - https://git.fd.io/ci-management/tree/jjb/vpp/vpp.yaml
   - jobs calling the script
     vpp-docs-merge-{stream}
     vpp-docs-verify-{stream}

Script
 - https://github.com/FDio/ci-management/blob/0c7d6e34945abfd03fe965ee4bbeaa7c290379dc/jjb/vpp/include-raw-vpp-docs.sh

Job configuration
 - https://git.fd.io/ci-management/tree/jjb/vpp/docs.yaml
   - jobs calling the script
     vpp-docs-verify-{stream}
     vpp-docs-merge-{stream}

Script
 - https://github.com/FDio/ci-management/blob/0c7d6e34945abfd03fe965ee4bbeaa7c290379dc/jjb/vpp/include-raw-vpp-docs.sh

Job configuration
 - https://git.fd.io/ci-management/tree/jjb/vpp/docs.yaml
   - jobs calling the script
     vpp-docs-merge-{stream}
     vpp-sphinx-docs-merge-{stream}

Script
 - https://github.com/FDio/ci-management/blob/0c7d6e34945abfd03fe965ee4bbeaa7c290379dc/jjb/vpp/include-raw-vpp-sphinx-docs.sh

Job configuration
 - https://git.fd.io/ci-management/tree/jjb/vpp/docs.yaml
   - jobs calling the script
     vpp-make-test-docs-verify-{stream}
     vpp-make-test-docs-merge-{stream}

Script
 - https://github.com/FDio/ci-management/blob/2cf6f067c034ab1544d96b286358c4c46484cd62/jjb/vpp/include-raw-vpp-make-test-docs.sh

CICN

Job configuration
 - https://git.fd.io/ci-management/tree/jjb/cicn/cicn.yaml
   - jobs calling script
     cicn-libparc-docs-merge-{stream}
     cicn-libparc-docs-verify-{stream}

Script
 - https://github.com/FDio/ci-management/blob/8acba0b988a3a6220340df3b0d79451fb52e93e9/jjb/cicn/include-raw-cicn-libparc-docs.sh

Job configuration
 - https://git.fd.io/ci-management/tree/jjb/cicn/cicn.yaml
   - jobs calling script
     cicn-longbow-docs-merge-{stream}
     cicn-longbow-docs-verify-{stream}

Script
 - https://github.com/FDio/ci-management/blob/8acba0b988a3a6220340df3b0d79451fb52e93e9/jjb/cicn/include-raw-cicn-longbow-docs.sh

HICN

Job configuration
 - https://git.fd.io/ci-management/tree/jjb/hicn/hicn-docs.yaml
   - jobs calling scripts
     hicn-docs-verify-{stream}
     hicn-docs-merge-{stream}

Script
 - https://github.com/FDio/ci-management/blob/eadf733ffe3c679e2eaaff83f2929c61d0f5daf5/jjb/hicn/include-raw-hicn-docs.sh

Honeycomb

https://github.com/FDio/honeycomb/blob/a776d7ff3e6f155a37b182dabaa0429fb2c04c3c/common/honeycomb-parent/pom.xml

        <!-- To support site push-->
        <extensions>
            <extension>
                <groupId>org.apache.maven.wagon</groupId>
                <artifactId>wagon-webdav-jackrabbit</artifactId>
                <version>2.9</version>
            </extension>
        </extensions>
    </build>

Thank you,
Vanessa

On 10/15/2019 03:17 PM, Vanessa Valderrama wrote:
Please modify build scripts and pom files to use apache maven wagon
version 3.x. Previous versions appear to conflict with Nexus causing
java.net.SocketTimeoutException: Read timed out errors.

Thank you,

Vanessa



Join honeycomb-dev@lists.fd.io to automatically receive all group messages.